SSL Certificate Issue

Incident Report for One Church Software

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 20:51 EDT

Update

This issue should be resolved now and the site accessible again.
Posted Apr 06, 2026 - 20:49 EDT

Identified

We are aware of an SSL certificate issue and are currently working on it. We'll follow up once this has been resolved.
Posted Apr 06, 2026 - 20:21 EDT
This incident affected: Management Portal, Public Portal, Check-In System, and One Church Giving.