Internet Outage Affecting Online Giving
Incident Report for One Church Software
Resolved
Microsoft has corrected the issue with Azure and all of our services are back online.
Posted Jul 18, 2024 - 23:26 EDT
Update
Update from Microsoft: We’ve determined the underlying cause and are currently applying mitigation. We will start to see incremental recovery in next 90 minutes.
Posted Jul 18, 2024 - 21:41 EDT
Update
Update from Microsoft:

Impact Statement: Starting at 21:56 UTC on 18 Jul 2024, a subset of customers may experience issues with multiple Azure services in the Central US region including failures with service management operations and connectivity or availability of services.

Current Status: We are aware of this issue and have engaged multiple teams to investigate. As part of the investigation, we are reviewing previous deployments, and are running other workstreams to investigate for an underlying cause.
Posted Jul 18, 2024 - 20:01 EDT
Identified
Usio, our merchant services provider, reports there is a major issue affecting many internet services including Microsoft Azure which is causing timeout issues with payment processing. They are monitoring the situation. We'll provide updates as we receive them.
Posted Jul 18, 2024 - 18:36 EDT
This incident affected: One Church Giving.