Payment Processing Outage

Incident Report for One Church Software

Resolved

Usio has resolved the issue, and payment processing should now be functioning normally again.
Posted Dec 09, 2025 - 10:43 EST

Investigating

Attempts to submit payments for processing is currently resulting in a 5004:System Error: Unable to load merchant details error. We have been in contact with Usio and they are investigating. We'll provide updates as they become available.
Posted Dec 09, 2025 - 10:29 EST
This incident affected: One Church Giving.