Payment processing unavailable
Incident Report for One Church Software
Resolved
The issue has been resolved and payment processing is back to normal.
Posted Sep 20, 2021 - 12:20 EDT
Investigating
Usio, our merchant services provider, is currently experiencing an issue. They are investigating the cause. Unfortunately, in the meantime, payment processing (i.e. online and text giving) is also unavailable.
Posted Sep 20, 2021 - 11:14 EDT
This incident affected: One Church Giving.