Background Screening Unavailable
Incident Report for One Church Software
Resolved
From Protect My Ministry:
Background Screening system services have been restored. You should now be able to order and view background checks.

The outage was caused by routing failures within a national internet provider’s network. Many companies across the U.S. were affected by the outage.

Our team will work as quickly as possible to recover from the downtime.
Posted Jun 29, 2021 - 14:07 EDT
Identified
Protect My Ministry has notified us that their background screening system is currently offline and unable to accept or process background screening orders. They are working to resolve the situation as quickly as possible and do not currently have an estimated time for service restoration.

We will update this status as more information is known.
Posted Jun 29, 2021 - 11:04 EDT
This incident affected: Management Portal.