Usio SSL Certificate Error
Incident Report for One Church Software
Resolved
The issue has been resolved and online giving should be working again.
Posted Oct 13, 2022 - 09:26 EDT
Investigating
Usio's SSL certificate has expired and they are working to renew it right now. Unfortunately, online giving is unavailable until this has been resolved.
Posted Oct 13, 2022 - 09:19 EDT
This incident affected: One Church Giving.